summaryrefslogtreecommitdiff
path: root/src/parser/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/parser/Makefile.am')
-rw-r--r--src/parser/Makefile.am33
1 files changed, 0 insertions, 33 deletions
diff --git a/src/parser/Makefile.am b/src/parser/Makefile.am
index 7ead35abd..a178f8dd5 100644
--- a/src/parser/Makefile.am
+++ b/src/parser/Makefile.am
@@ -20,13 +20,9 @@ AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
SUBDIRS = smt1 smt2 cvc tptp
lib_LTLIBRARIES = libcvc4parser.la
-if HAVE_CXXTESTGEN
-check_LTLIBRARIES = libcvc4parser_noinst.la
-endif
libcvc4parser_la_LDFLAGS = $(ANTLR_LDFLAGS) \
-version-info $(LIBCVC4PARSER_VERSION)
-libcvc4parser_noinst_la_LDFLAGS = $(ANTLR_LDFLAGS)
libcvc4parser_la_LIBADD = \
@builddir@/smt1/libparsersmt1.la \
@@ -34,18 +30,10 @@ libcvc4parser_la_LIBADD = \
@builddir@/tptp/libparsertptp.la \
@builddir@/cvc/libparsercvc.la \
-L@builddir@/.. -lcvc4
-libcvc4parser_noinst_la_LIBADD = \
- @builddir@/smt1/libparsersmt1.la \
- @builddir@/smt2/libparsersmt2.la \
- @builddir@/tptp/libparsertptp.la \
- @builddir@/cvc/libparsercvc.la \
- @builddir@/../libcvc4_noinst.la
if CVC4_NEEDS_REPLACEMENT_FUNCTIONS
libcvc4parser_la_LIBADD += \
@builddir@/../lib/libreplacements.la
-libcvc4parser_noinst_la_LIBADD += \
- @builddir@/../lib/libreplacements.la
endif
libcvc4parser_la_SOURCES = \
@@ -69,27 +57,6 @@ libcvc4parser_la_SOURCES = \
parser_exception.h \
antlr_tracing.h
-libcvc4parser_noinst_la_SOURCES = \
- antlr_input.h \
- antlr_input.cpp \
- antlr_input_imports.cpp \
- antlr_line_buffered_input.h \
- antlr_line_buffered_input.cpp \
- bounded_token_buffer.h \
- bounded_token_buffer.cpp \
- bounded_token_factory.h \
- bounded_token_factory.cpp \
- input.h \
- input.cpp \
- memory_mapped_input_buffer.h \
- memory_mapped_input_buffer.cpp \
- parser.h \
- parser.cpp \
- parser_builder.h \
- parser_builder.cpp \
- parser_exception.h \
- antlr_tracing.h
-
EXTRA_DIST = \
Makefile.antlr_tracing \
cvc4parser.i \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback