summaryrefslogtreecommitdiff
path: root/src/parser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/parser/CMakeLists.txt')
-rw-r--r--src/parser/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/parser/CMakeLists.txt b/src/parser/CMakeLists.txt
index 6cde56c62..d7491f8ca 100644
--- a/src/parser/CMakeLists.txt
+++ b/src/parser/CMakeLists.txt
@@ -82,6 +82,10 @@ foreach(lang Cvc Smt1 Smt2 Tptp)
set_source_files_properties(${gen_src_files} PROPERTIES LANGUAGE CXX)
set_source_files_properties(${gen_src_files} PROPERTIES GENERATED TRUE)
+ # We don't want to enable -Wall for code generated by ANTLR.
+ set_source_files_properties(
+ ${gen_src_files} PROPERTIES COMPILE_FLAGS -Wno-all)
+
# Add generated source files to the parser source files
list(APPEND libcvc4parser_src_files ${gen_src_files})
endforeach()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback