summaryrefslogtreecommitdiff
path: root/src/parser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/parser/CMakeLists.txt')
-rw-r--r--src/parser/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/parser/CMakeLists.txt b/src/parser/CMakeLists.txt
index ce4b354f3..6a7f77ea3 100644
--- a/src/parser/CMakeLists.txt
+++ b/src/parser/CMakeLists.txt
@@ -24,6 +24,13 @@ set(cvc4parser_src_files
)
add_library(cvc4parser ${cvc4parser_src_files})
+
+set_target_properties(cvc4parser
+ PROPERTIES
+ VERSION ${CVC4_VERSION}
+ SOVERSION ${CVC4_SOVERSION}
+)
+
target_compile_definitions(cvc4parser PRIVATE -D__BUILDING_CVC4PARSERLIB)
target_link_libraries(cvc4parser parsercvc parsersmt1 parsersmt2 parsertptp cvc4)
target_link_libraries(cvc4parser ${ANTLR_LIBRARIES})
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback