summaryrefslogtreecommitdiff
path: root/src/parser/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/parser/CMakeLists.txt')
-rw-r--r--src/parser/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/parser/CMakeLists.txt b/src/parser/CMakeLists.txt
index dcb580d8f..8c0a65fa7 100644
--- a/src/parser/CMakeLists.txt
+++ b/src/parser/CMakeLists.txt
@@ -1,3 +1,32 @@
+set(cvc4parser_src_files
+ antlr_input.cpp
+ antlr_input.h
+ antlr_input_imports.cpp
+ antlr_line_buffered_input.cpp
+ antlr_line_buffered_input.h
+ antlr_tracing.h
+ antlr_undefines.h
+ bounded_token_buffer.cpp
+ bounded_token_buffer.h
+ bounded_token_factory.cpp
+ bounded_token_factory.h
+ input.cpp
+ input.h
+ line_buffer.cpp
+ line_buffer.h
+ memory_mapped_input_buffer.cpp
+ memory_mapped_input_buffer.h
+ parser.cpp
+ parser.h
+ parser_builder.cpp
+ parser_builder.h
+ parser_exception.h
+)
+
+add_library(cvc4parser SHARED ${cvc4parser_src_files})
+set_target_properties(cvc4parser PROPERTIES COMPILE_DEFINITIONS __BUILDING_CVC4PARSERLIB)
+target_link_libraries(cvc4parser parsercvc parsersmt1 parsersmt2 parsertptp cvc4)
+
add_subdirectory(cvc)
add_subdirectory(smt1)
add_subdirectory(smt2)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback