summaryrefslogtreecommitdiff
path: root/src/options/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/options/Makefile.am')
-rw-r--r--src/options/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/options/Makefile.am b/src/options/Makefile.am
index 19aa43c98..ad0ec7914 100644
--- a/src/options/Makefile.am
+++ b/src/options/Makefile.am
@@ -148,7 +148,7 @@ BUILT_SOURCES += \
%_tags.h: %_tags mktagheaders
$(AM_V_at)chmod +x @srcdir@/mktagheaders
- $(AM_V_GEN)( @srcdir@/mktagheaders "$<" ) >"$@"
+ $(AM_V_GEN)( @srcdir@/mktagheaders "$<" "$<" ) >"$@"
# This .tmp business is to keep from having to re-compile options.cpp
# (and then re-link the libraries) if nothing has changed.
@@ -162,7 +162,9 @@ BUILT_SOURCES += \
# expression (no |, no \<, ...).
Debug_tags.tmp Trace_tags.tmp: mktags
$(AM_V_at)chmod +x @srcdir@/mktags
- $(AM_V_GEN)(@srcdir@/mktags '$(@:_tags.tmp=)' '@srcdir@/../') >"$@"
+ $(AM_V_GEN)(@srcdir@/mktags \
+ '$(@:_tags.tmp=)' \
+ "$$(find @srcdir@/../ -name '*.cpp' -o -name '*.h' -o -name '*.cc' -o -name '*.g')") >"$@"
MOSTLYCLEANFILES = \
Debug_tags \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback