summaryrefslogtreecommitdiff
path: root/src/options/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/options/CMakeLists.txt')
-rw-r--r--src/options/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/options/CMakeLists.txt b/src/options/CMakeLists.txt
index 926693185..a548717f3 100644
--- a/src/options/CMakeLists.txt
+++ b/src/options/CMakeLists.txt
@@ -29,7 +29,6 @@ libcvc5_add_sources(
options_handler.cpp
options_handler.h
options_listener.h
- options_public.cpp
options_public.h
outputc.cpp
outputc.h
@@ -67,7 +66,7 @@ set(options_toml_files
string(REPLACE "toml" "cpp;" options_gen_cpp_files ${options_toml_files})
string(REPLACE "toml" "h;" options_gen_h_files ${options_toml_files})
-libcvc5_add_sources(GENERATED options.h options.cpp ${options_gen_cpp_files})
+libcvc5_add_sources(GENERATED options.h options.cpp options_public.cpp ${options_gen_cpp_files})
list_prepend(options_toml_files "${CMAKE_CURRENT_LIST_DIR}/" abs_toml_files)
@@ -82,7 +81,7 @@ endif()
add_custom_command(
OUTPUT
- options.h options.cpp
+ options.h options.cpp options_public.cpp
${options_gen_cpp_files} ${options_gen_h_files}
${options_gen_doc_files}
COMMAND
@@ -97,6 +96,7 @@ add_custom_command(
${options_toml_files}
module_template.h
module_template.cpp
+ options_public_template.cpp
options_template.h
options_template.cpp
)
@@ -105,6 +105,7 @@ add_custom_target(gen-options
DEPENDS
options.h
options.cpp
+ options_public.cpp
${options_gen_cpp_files}
${options_gen_h_files}
)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback