summaryrefslogtreecommitdiff
path: root/src/options/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/options/CMakeLists.txt')
-rw-r--r--src/options/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/options/CMakeLists.txt b/src/options/CMakeLists.txt
index 38f68461b..078c2ad31 100644
--- a/src/options/CMakeLists.txt
+++ b/src/options/CMakeLists.txt
@@ -27,7 +27,6 @@ libcvc5_add_sources(
open_ostream.h
option_exception.cpp
option_exception.h
- options.h
options_handler.cpp
options_handler.h
options_listener.h
@@ -67,13 +66,13 @@ set(options_toml_files
string(REPLACE "toml" "cpp;" options_gen_cpp_files ${options_toml_files})
string(REPLACE "toml" "h;" options_gen_h_files ${options_toml_files})
-libcvc5_add_sources(GENERATED options.cpp ${options_gen_cpp_files})
+libcvc5_add_sources(GENERATED options.h options.cpp ${options_gen_cpp_files})
list_prepend(options_toml_files "${CMAKE_CURRENT_LIST_DIR}/" abs_toml_files)
add_custom_command(
OUTPUT
- options.cpp options_holder.h
+ options.h options.cpp
${options_gen_cpp_files} ${options_gen_h_files}
COMMAND
${PYTHON_EXECUTABLE}
@@ -86,14 +85,14 @@ add_custom_command(
${options_toml_files}
module_template.h
module_template.cpp
- options_holder_template.h
+ options_template.h
options_template.cpp
)
add_custom_target(gen-options
DEPENDS
+ options.h
options.cpp
- options_holder.h
${options_gen_cpp_files}
${options_gen_h_files}
)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback