summaryrefslogtreecommitdiff
path: root/src/main/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/main/CMakeLists.txt')
-rw-r--r--src/main/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/main/CMakeLists.txt b/src/main/CMakeLists.txt
index 029397832..27086d3fb 100644
--- a/src/main/CMakeLists.txt
+++ b/src/main/CMakeLists.txt
@@ -19,17 +19,22 @@ set(libmain_src_files
interactive_shell.cpp
interactive_shell.h
main.h
+ options.h
signal_handlers.cpp
signal_handlers.h
time_limit.cpp
time_limit.h
)
+set(libmain_gen_src_files
+ ${CMAKE_CURRENT_BINARY_DIR}/options.cpp
+)
+set_source_files_properties(${libmain_gen_src_files} PROPERTIES GENERATED TRUE)
#-----------------------------------------------------------------------------#
# Build object library since we will use the object files for cvc5-bin and
# main-test library.
-add_library(main OBJECT ${libmain_src_files})
+add_library(main OBJECT ${libmain_src_files} ${libmain_gen_src_files})
target_compile_definitions(main PRIVATE -D__BUILDING_CVC5DRIVER)
if(ENABLE_SHARED)
set_target_properties(main PROPERTIES POSITION_INDEPENDENT_CODE ON)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback