summaryrefslogtreecommitdiff
path: root/src/main/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/main/CMakeLists.txt')
-rw-r--r--src/main/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/main/CMakeLists.txt b/src/main/CMakeLists.txt
index 51809975c..473fc927a 100644
--- a/src/main/CMakeLists.txt
+++ b/src/main/CMakeLists.txt
@@ -77,7 +77,7 @@ endif()
# https://cmake.org/cmake/help/v3.0/prop_tgt/LINK_SEARCH_START_STATIC.html
# https://cmake.org/cmake/help/v3.0/prop_tgt/LINK_SEARCH_END_STATIC.html
if(NOT BUILD_SHARED_LIBS)
- if(NOT CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ if(STATIC_BINARY)
set_target_properties(cvc5-bin PROPERTIES LINK_FLAGS -static)
set_target_properties(cvc5-bin PROPERTIES LINK_SEARCH_START_STATIC ON)
set_target_properties(cvc5-bin PROPERTIES LINK_SEARCH_END_STATIC ON)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback