summaryrefslogtreecommitdiff
path: root/src/main/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/main/CMakeLists.txt')
-rw-r--r--src/main/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/main/CMakeLists.txt b/src/main/CMakeLists.txt
index be9575f5d..5fb555d70 100644
--- a/src/main/CMakeLists.txt
+++ b/src/main/CMakeLists.txt
@@ -56,7 +56,7 @@ endif()
# use the static system libraries.
# https://cmake.org/cmake/help/v3.0/prop_tgt/LINK_SEARCH_START_STATIC.html
# https://cmake.org/cmake/help/v3.0/prop_tgt/LINK_SEARCH_END_STATIC.html
-if(NOT ENABLE_SHARED)
+if(ENABLE_STATIC_BINARY)
set_target_properties(cvc4-bin PROPERTIES LINK_FLAGS -static)
set_target_properties(cvc4-bin PROPERTIES LINK_SEARCH_START_STATIC ON)
set_target_properties(cvc4-bin PROPERTIES LINK_SEARCH_END_STATIC ON)
@@ -90,7 +90,7 @@ if(ENABLE_PORTFOLIO)
install(TARGETS pcvc4-bin DESTINATION bin)
endif()
- if(NOT ENABLE_SHARED)
+ if(ENABLE_STATIC_BINARY)
set_target_properties(pcvc4-bin PROPERTIES LINK_FLAGS -static)
set_target_properties(pcvc4-bin PROPERTIES LINK_SEARCH_START_STATIC ON)
set_target_properties(pcvc4-bin PROPERTIES LINK_SEARCH_END_STATIC ON)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback