summaryrefslogtreecommitdiff
path: root/src/main/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/main/CMakeLists.txt')
-rw-r--r--src/main/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/src/main/CMakeLists.txt b/src/main/CMakeLists.txt
index fad4e77c5..356b0e199 100644
--- a/src/main/CMakeLists.txt
+++ b/src/main/CMakeLists.txt
@@ -62,48 +62,10 @@ if(ENABLE_STATIC_BINARY)
set_target_properties(cvc4-bin PROPERTIES LINK_SEARCH_END_STATIC ON)
endif()
-if(ENABLE_PORTFOLIO)
- set(pcvc4_src_files
- command_executor_portfolio.cpp
- command_executor_portfolio.h
- driver_unified.cpp
- main.cpp
- portfolio.cpp
- portfolio.h
- portfolio_util.cpp
- portfolio_util.h
- )
-
- add_executable(pcvc4-bin ${pcvc4_src_files} $<TARGET_OBJECTS:main>)
- target_compile_definitions(pcvc4-bin PRIVATE -D__BUILDING_CVC4DRIVER)
- target_compile_definitions(pcvc4-bin PRIVATE -DPORTFOLIO_BUILD)
- set_target_properties(pcvc4-bin
- PROPERTIES
- OUTPUT_NAME pcvc4
- RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
- target_link_libraries(pcvc4-bin cvc4 cvc4parser ${Boost_LIBRARIES})
- target_include_directories(pcvc4-bin PRIVATE ${Boost_INCLUDE_DIRS})
- if(PROGRAM_PREFIX)
- install(PROGRAMS
- $<TARGET_FILE:pcvc4-bin> DESTINATION bin RENAME ${PROGRAM_PREFIX}pcvc4)
- else()
- install(TARGETS pcvc4-bin DESTINATION bin)
- endif()
-
- if(ENABLE_STATIC_BINARY)
- set_target_properties(pcvc4-bin PROPERTIES LINK_FLAGS -static)
- set_target_properties(pcvc4-bin PROPERTIES LINK_SEARCH_START_STATIC ON)
- set_target_properties(pcvc4-bin PROPERTIES LINK_SEARCH_END_STATIC ON)
- endif()
-endif()
-
if(USE_READLINE)
target_link_libraries(cvc4-bin ${Readline_LIBRARIES})
target_link_libraries(main-test ${Readline_LIBRARIES})
target_include_directories(main PRIVATE ${Readline_INCLUDE_DIR})
- if(ENABLE_PORTFOLIO)
- target_link_libraries(pcvc4-bin ${Readline_LIBRARIES})
- endif()
endif()
#-----------------------------------------------------------------------------#
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback