summaryrefslogtreecommitdiff
path: root/src/main/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/main/CMakeLists.txt')
-rw-r--r--src/main/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/main/CMakeLists.txt b/src/main/CMakeLists.txt
index e69de29bb..1a586f834 100644
--- a/src/main/CMakeLists.txt
+++ b/src/main/CMakeLists.txt
@@ -0,0 +1,36 @@
+set(libmain_src_files
+ interactive_shell.cpp
+ interactive_shell.h
+ main.h
+ util.cpp
+)
+
+add_library(main SHARED ${libmain_src_files})
+set_target_properties(main PROPERTIES COMPILE_DEFINITIONS __BUILDING_CVC4DRIVER)
+target_link_libraries(main cvc4 cvc4parser)
+
+set(cvc4main_src_files
+ command_executor.cpp
+ driver_unified.cpp
+ main.cpp
+)
+
+add_executable(cvc4-main ${cvc4main_src_files})
+set_target_properties(cvc4-main
+ PROPERTIES
+ OUTPUT_NAME cvc4
+ COMPILE_DEFINITIONS __BUILDING_CVC4DRIVER)
+target_link_libraries(cvc4-main main) #cvc4 cvc4parser replacements)
+
+#set(pcvc4_src_files
+# main.cpp
+# portfolio.cpp
+# portfolio.h
+# portfolio_util.cpp
+# portfolio_util.h
+# command_executor.cpp
+# command_executor_portfolio.cpp
+# command_executor.h
+# command_executor_portfolio.h
+# driver_unified.cpp
+#)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback