summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index 2400468a2..06a252b3c 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -67,6 +67,7 @@ libexpr_la_SOURCES = \
nodist_libexpr_la_SOURCES = \
kind.h \
+ kind.cpp \
metakind.h \
type_properties.h \
expr.h \
@@ -83,6 +84,7 @@ EXTRA_DIST = \
datatype.i \
emptyset.i \
kind_template.h \
+ kind_template.cpp \
metakind_template.h \
type_properties_template.h \
expr_manager_template.h \
@@ -105,6 +107,7 @@ EXTRA_DIST = \
BUILT_SOURCES = \
kind.h \
+ kind.cpp \
metakind.h \
type_properties.h \
expr.h \
@@ -116,6 +119,7 @@ BUILT_SOURCES = \
CLEANFILES = \
kind.h \
+ kind.cpp \
metakind.h \
expr.h \
expr.cpp \
@@ -142,6 +146,14 @@ kind.h: kind_template.h mkkind @top_builddir@/src/expr/.subdirs $(if $(COVERAGE_
`cat @top_builddir@/src/expr/.subdirs` \
> $@) || (rm -f $@ && exit 1)
+kind.cpp: kind_template.cpp mkkind @top_builddir@/src/expr/.subdirs $(if $(COVERAGE_ON), @abs_top_srcdir@, @top_srcdir@)/src/theory/*/kinds
+ $(AM_V_at)chmod +x @srcdir@/mkkind
+ $(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
+ $(AM_V_GEN)(@srcdir@/mkkind \
+ $< \
+ `cat @top_builddir@/src/expr/.subdirs` \
+ > $@) || (rm -f $@ && exit 1)
+
metakind.h: metakind_template.h mkmetakind @top_builddir@/src/expr/.subdirs $(if $(COVERAGE_ON), @abs_top_srcdir@, @top_srcdir@)/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mkmetakind
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback