summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index c04de4421..d5f8de462 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -1,6 +1,19 @@
+# Forcing some make variables to be actual absolute paths to fix Coverage
+# lcov does not support relative paths and src/options and src/expr
+# in particular were breaking it
+# Note: variable declarations may be moved in generated Makefile
+# see src/expr/Makefile.am
+
+VPATH = $(realpath @srcdir@)
+srcdir = $(realpath @srcdir@)
+abs_srcdir = $(realpath @abs_srcdir@)
+abs_top_srcdir = $(realpath @abs_top_srcdir@)
+top_srcdir = $(realpath @top_srcdir@)
+
+
AM_CPPFLAGS = \
-D__BUILDING_CVC4LIB \
- -I@builddir@/.. -I@srcdir@/../include -I@srcdir@/..
+ -I$(realpath @builddir@/..) -I$(realpath @srcdir@/../include) -I$(realpath @srcdir@/..)
AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
noinst_LTLIBRARIES = libexpr.la
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback