summaryrefslogtreecommitdiff
path: root/src/expr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/expr/Makefile.am')
-rw-r--r--src/expr/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/expr/Makefile.am b/src/expr/Makefile.am
index 1d7af717b..4ed5a3ac7 100644
--- a/src/expr/Makefile.am
+++ b/src/expr/Makefile.am
@@ -31,6 +31,7 @@ libexpr_la_SOURCES = \
nodist_libexpr_la_SOURCES = \
kind.h \
metakind.h \
+ type_properties.h \
expr.h \
expr.cpp \
expr_manager.h \
@@ -39,6 +40,7 @@ nodist_libexpr_la_SOURCES = \
EXTRA_DIST = \
kind_template.h \
metakind_template.h \
+ type_properties_template.h \
expr_manager_template.h \
expr_manager_template.cpp \
expr_template.h \
@@ -50,6 +52,7 @@ EXTRA_DIST = \
BUILT_SOURCES = \
kind.h \
metakind.h \
+ type_properties.h \
expr.h \
expr.cpp \
expr_manager.h \
@@ -83,6 +86,14 @@ metakind.h: metakind_template.h mkmetakind @top_builddir@/src/theory/.subdirs @t
`cat @top_builddir@/src/theory/.subdirs` \
> $@) || (rm -f $@ && exit 1)
+type_properties.h: type_properties_template.h mkkind @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
+ $(AM_V_at)chmod +x @srcdir@/mkkind
+ $(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
+ $(AM_V_GEN)(@srcdir@/mkkind \
+ $< \
+ `cat @top_builddir@/src/theory/.subdirs` \
+ > $@) || (rm -f $@ && exit 1)
+
expr.h: expr_template.h mkexpr @top_builddir@/src/theory/.subdirs @top_srcdir@/src/theory/*/kinds
$(AM_V_at)chmod +x @srcdir@/mkexpr
$(AM_V_at)$(am__mv) $@ $@~ 2>/dev/null || true
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback