summaryrefslogtreecommitdiff
path: root/src/context/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/context/CMakeLists.txt')
-rw-r--r--src/context/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/context/CMakeLists.txt b/src/context/CMakeLists.txt
index 6cc066235..00b4d91ee 100644
--- a/src/context/CMakeLists.txt
+++ b/src/context/CMakeLists.txt
@@ -34,7 +34,5 @@ set(LIBCONTEXT_SOURCES
)
add_library(cvc5context OBJECT ${LIBCONTEXT_SOURCES})
-if(ENABLE_SHARED)
- set_target_properties(cvc5context PROPERTIES POSITION_INDEPENDENT_CODE ON)
-endif()
+set_target_properties(cvc5context PROPERTIES POSITION_INDEPENDENT_CODE ON)
target_compile_definitions(cvc5context PRIVATE -D__BUILDING_CVC5LIB)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback