summaryrefslogtreecommitdiff
path: root/src/compat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/compat/Makefile.am')
-rw-r--r--src/compat/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/compat/Makefile.am b/src/compat/Makefile.am
new file mode 100644
index 000000000..905eaa6c4
--- /dev/null
+++ b/src/compat/Makefile.am
@@ -0,0 +1,50 @@
+# LIBCVC4COMPAT_VERSION (-version-info) is in the form current:revision:age
+#
+# current -
+# increment if interfaces have been added, removed or changed
+# revision -
+# increment if source code has changed
+# set to zero if current is incremented
+# age -
+# increment if interfaces have been added
+# set to zero if interfaces have been removed
+# or changed
+#
+LIBCVC4COMPAT_VERSION = @CVC4_COMPAT_LIBRARY_VERSION@
+
+AM_CPPFLAGS = \
+ -D__BUILDING_CVC4COMPATLIB \
+ -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/.. $(ANTLR_INCLUDES)
+AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
+
+if CVC4_BUILD_LIBCOMPAT
+
+nobase_lib_LTLIBRARIES = libcvc4compat.la
+if HAVE_CXXTESTGEN
+noinst_LTLIBRARIES = libcvc4compat_noinst.la
+endif
+
+libcvc4compat_la_LDFLAGS = \
+ -version-info $(LIBCVC4COMPAT_VERSION)
+libcvc4compat_noinst_la_LDFLAGS =
+
+libcvc4compat_la_LIBADD = \
+ @builddir@/../lib/libreplacements.la
+libcvc4compat_noinst_la_LIBADD = \
+ @builddir@/../lib/libreplacements.la
+
+libcvc4compat_la_SOURCES = \
+ cvc3_compat.h \
+ cvc3_compat.cpp
+
+libcvc4compat_noinst_la_SOURCES = \
+ cvc3_compat.h \
+ cvc3_compat.cpp
+
+else
+
+EXTRA_DIST = \
+ cvc3_compat.h \
+ cvc3_compat.cpp
+
+endif
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback