summaryrefslogtreecommitdiff
path: root/src/compat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/compat/CMakeLists.txt')
-rw-r--r--src/compat/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/compat/CMakeLists.txt b/src/compat/CMakeLists.txt
index 92b6aabfa..f327de593 100644
--- a/src/compat/CMakeLists.txt
+++ b/src/compat/CMakeLists.txt
@@ -3,7 +3,6 @@ set(compat_src_files
cvc3_compat.h
)
-add_library(cvc4compat SHARED ${compat_src_files})
-set_target_properties(cvc4compat
- PROPERTIES COMPILE_DEFINITIONS __BUILDING_CVC4COMPATLIB)
+add_library(cvc4compat ${compat_src_files})
+target_compile_definitions(cvc4compat PRIVATE -D__BUILDING_CVC4COMPATLIB)
target_link_libraries(cvc4compat cvc4)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback