summaryrefslogtreecommitdiff
path: root/src/bindings/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/bindings/Makefile.am')
-rw-r--r--src/bindings/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/bindings/Makefile.am b/src/bindings/Makefile.am
index bd0bad6ba..fbecad29a 100644
--- a/src/bindings/Makefile.am
+++ b/src/bindings/Makefile.am
@@ -16,7 +16,7 @@ AUTOMAKE_OPTIONS = subdir-objects
AM_CPPFLAGS = \
-D__BUILDING_CVC4BINDINGSLIB \
- -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/..
+ -I@builddir@/.. -I@srcdir@/../include -I@srcdir@/..
AM_CXXFLAGS = -Wall
SUBDIRS = compat
@@ -217,10 +217,10 @@ if CVC4_HAS_SWIG
$(patsubst %,%.cpp,$(filter-out c c++,$(CVC4_LANGUAGE_BINDINGS))): %.cpp: @srcdir@/../cvc4.i
$(AM_V_at)mkdir -p $(patsubst %.cpp,%,$@)
- $(AM_V_GEN)$(SWIG) -Wall -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/.. -c++ -$(patsubst %.cpp,%,$@) -outdir $(patsubst %.cpp,%,$@) $($(subst .,_,$@)_SWIGFLAGS) -o $@ $<
+ $(AM_V_GEN)$(SWIG) -Wall -I@builddir@/.. -c++ -$(patsubst %.cpp,%,$@) -outdir $(patsubst %.cpp,%,$@) $($(subst .,_,$@)_SWIGFLAGS) -o $@ $< -I@srcdir@/../include -I@srcdir@/..
$(patsubst %,%.d,$(filter-out c c++,$(CVC4_LANGUAGE_BINDINGS))): %.d: @srcdir@/../cvc4.i
- $(AM_V_GEN)$(SWIG) -I@srcdir@/../include -I@srcdir@/.. -I@builddir@/.. -c++ -$(patsubst %.d,%,$@) -MM -o $(patsubst %.d,%.cpp,$@) $<
+ $(AM_V_GEN)$(SWIG) -I@builddir@/.. -c++ -$(patsubst %.d,%,$@) -MM -o $(patsubst %.d,%.cpp,$@) $< -I@srcdir@/../include -I@srcdir@/..
# .PHONY so they get rebuilt each time
.PHONY: .swig_deps $(patsubst %,%.d,$(filter-out c c++,$(CVC4_LANGUAGE_BINDINGS)))
.swig_deps: $(patsubst %,%.d,$(filter-out c c++,$(CVC4_LANGUAGE_BINDINGS)))
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback