summaryrefslogtreecommitdiff
path: root/src/base/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/base/Makefile.am')
-rw-r--r--src/base/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/src/base/Makefile.am b/src/base/Makefile.am
index 491baaa90..5537bbbdd 100644
--- a/src/base/Makefile.am
+++ b/src/base/Makefile.am
@@ -5,7 +5,7 @@ AM_CXXFLAGS = -Wall -Wno-unknown-pragmas $(FLAG_VISIBILITY_HIDDEN)
noinst_LTLIBRARIES = libbase.la
-# Do not list built sources (like tls.h) here!
+# Do not list built sources here!
# Rather, list them under BUILT_SOURCES, and their .in versions under
# EXTRA_DIST. Otherwise, they're packaged up in the tarball, which is
# no good---they belong in the configured builds/ directory. If they
@@ -26,17 +26,14 @@ libbase_la_SOURCES = \
listener.h \
modal_exception.h \
output.cpp \
- output.h
-
-
-BUILT_SOURCES = \
+ output.h \
tls.h
# listing {Debug,Trace}_tags too ensures that make doesn't auto-remove it
# after building (if it does, we don't get the "cached" effect with
# the .tmp files below, and we have to re-compile and re-link each
# time, even when there are no changes).
-BUILT_SOURCES += \
+BUILT_SOURCES = \
Debug_tags.h \
Debug_tags \
Trace_tags.h \
@@ -55,12 +52,7 @@ EXTRA_DIST = \
exception.i \
mktagheaders \
mktags \
- modal_exception.i \
- tls.h.in
-
-DISTCLEANFILES = \
- tls.h.tmp \
- tls.h
+ modal_exception.i
%_tags.h: %_tags mktagheaders
$(AM_V_at)chmod +x @srcdir@/mktagheaders
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback