summaryrefslogtreecommitdiff
path: root/src/api/python/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/api/python/CMakeLists.txt')
-rw-r--r--src/api/python/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/api/python/CMakeLists.txt b/src/api/python/CMakeLists.txt
index e6a0c71c5..b400c14e5 100644
--- a/src/api/python/CMakeLists.txt
+++ b/src/api/python/CMakeLists.txt
@@ -49,10 +49,15 @@ add_library(pycvc4
target_link_libraries(pycvc4 cvc4 ${PYTHON_LIBRARIES})
# Disable -Werror and other warnings for code generated by Cython.
+# Note: Visibility is reset to default here since otherwise the PyInit_...
+# function will not be exported correctly
+# (https://github.com/cython/cython/issues/3380).
set_target_properties(pycvc4
PROPERTIES
COMPILE_FLAGS
- "-Wno-error -Wno-shadow -Wno-implicit-fallthrough")
+ "-Wno-error -Wno-shadow -Wno-implicit-fallthrough"
+ CXX_VISIBILITY_PRESET default
+ VISIBILITY_INLINES_HIDDEN 0)
python_extension_module(pycvc4)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback