summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ca22263fd..b79eddf8b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,9 +21,13 @@ publicheaders = \
include/cvc4_config.h \
include/cvc4_expr.h
-install-data-local:
+install-data-local: $(publicheaders)
$(mkinstalldirs) $(DESTDIR)$(includedir)/cvc4; \
@for f in $(publicheaders); do
echo $(INSTALL_DATA) "$(srcdir)/$$f" "$(DESTDIR)/$(includedir)/cvc4"
$(INSTALL_DATA) "$(srcdir)/$$f" "$(DESTDIR)/$(includedir)/cvc4"
done
+
+include/cvc4.h: smt/smt_engine.h
+ @srcdir@/headergen.pl $< $@
+include/cvc4_expr.h: expr/expr.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback