summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 23 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 128e47bd5..afbb587a8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,3 +1,20 @@
+# LIBCVC4_VERSION (-version-info) is in the form current:revision:age
+#
+# current -
+# increment if interfaces have been added, removed or changed
+# revision -
+# increment if source code has changed
+# set to zero if current is incremented
+# age -
+# increment if interfaces have been added
+# set to zero if interfaces have been removed
+# or changed
+#
+# LIBCVC4_RELEASE (-release) should match the CVC4 release version
+#
+LIBCVC4_RELEASE = @CVC4_LIBRARY_RELEASE_CODE@
+LIBCVC4_VERSION = @CVC4_LIBRARY_VERSION@
+
INCLUDES = -I@srcdir@/include -I@srcdir@
AM_CXXFLAGS = -Wall -fvisibility=hidden
AM_CPPFLAGS = -D__BUILDING_CVC4LIB
@@ -6,6 +23,8 @@ SUBDIRS = util expr context prop smt theory . parser main
lib_LTLIBRARIES = libcvc4.la
+libcvc4_la_LDFLAGS = -version-info $(LIBCVC4_VERSION) -release $(LIBCVC4_RELEASE)
+
libcvc4_la_SOURCES =
libcvc4_la_LIBADD = \
@builddir@/util/libutil.la \
@@ -22,10 +41,10 @@ publicheaders = \
include/cvc4_expr.h
install-data-local: $(publicheaders)
- $(mkinstalldirs) $(DESTDIR)$(includedir)/cvc4; \
- @for f in $(publicheaders); do
- echo $(INSTALL_DATA) "$(srcdir)/$$f" "$(DESTDIR)/$(includedir)/cvc4"
- $(INSTALL_DATA) "$(srcdir)/$$f" "$(DESTDIR)/$(includedir)/cvc4"
+ $(mkinstalldirs) $(DESTDIR)$(includedir)/cvc4
+ @for f in $(publicheaders); do \
+ echo $(INSTALL_DATA) "$(srcdir)/$$f" "$(DESTDIR)/$(includedir)/cvc4"; \
+ $(INSTALL_DATA) "$(srcdir)/$$f" "$(DESTDIR)/$(includedir)/cvc4"; \
done
include/cvc4.h: smt/smt_engine.h
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback