summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9a1cfe9e7..7ecee2dee 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -124,6 +124,8 @@ libcvc4_add_sources(
printer/tptp/tptp_printer.h
proof/arith_proof.cpp
proof/arith_proof.h
+ proof/arith_proof_recorder.cpp
+ proof/arith_proof_recorder.h
proof/array_proof.cpp
proof/array_proof.h
proof/bitvector_proof.cpp
@@ -142,6 +144,8 @@ libcvc4_add_sources(
proof/proof_output_channel.h
proof/proof_utils.cpp
proof/proof_utils.h
+ proof/resolution_bitvector_proof.cpp
+ proof/resolution_bitvector_proof.h
proof/sat_proof.h
proof/sat_proof_implementation.h
proof/simplify_boolean_node.cpp
@@ -202,6 +206,7 @@ libcvc4_add_sources(
prop/sat_solver.h
prop/sat_solver_factory.cpp
prop/sat_solver_factory.h
+ prop/bv_sat_solver_notify.h
prop/sat_solver_types.h
prop/theory_proxy.cpp
prop/theory_proxy.h
@@ -472,8 +477,6 @@ libcvc4_add_sources(
theory/quantifiers/extended_rewrite.h
theory/quantifiers/first_order_model.cpp
theory/quantifiers/first_order_model.h
- theory/quantifiers/fmf/ambqi_builder.cpp
- theory/quantifiers/fmf/ambqi_builder.h
theory/quantifiers/fmf/bounded_integers.cpp
theory/quantifiers/fmf/bounded_integers.h
theory/quantifiers/fmf/full_model_check.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback