summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 366e72af0..869699ac5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -219,6 +219,8 @@ libcvc4_add_sources(
smt/dump.h
smt/dump_manager.cpp
smt/dump_manager.h
+ smt/expand_definitions.cpp
+ smt/expand_definitions.h
smt/listeners.cpp
smt/listeners.h
smt/logic_exception.h
@@ -387,8 +389,16 @@ libcvc4_add_sources(
theory/arith/nl/stats.h
theory/arith/nl/strategy.cpp
theory/arith/nl/strategy.h
- theory/arith/nl/transcendental_solver.cpp
- theory/arith/nl/transcendental_solver.h
+ theory/arith/nl/transcendental/exponential_solver.cpp
+ theory/arith/nl/transcendental/exponential_solver.h
+ theory/arith/nl/transcendental/sine_solver.cpp
+ theory/arith/nl/transcendental/sine_solver.h
+ theory/arith/nl/transcendental/taylor_generator.cpp
+ theory/arith/nl/transcendental/taylor_generator.h
+ theory/arith/nl/transcendental/transcendental_solver.cpp
+ theory/arith/nl/transcendental/transcendental_solver.h
+ theory/arith/nl/transcendental/transcendental_state.cpp
+ theory/arith/nl/transcendental/transcendental_state.h
theory/arith/normal_form.cpp
theory/arith/normal_form.h
theory/arith/operator_elim.cpp
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback