summaryrefslogtreecommitdiff
path: root/examples/sets-translate/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/sets-translate/CMakeLists.txt')
-rw-r--r--examples/sets-translate/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/examples/sets-translate/CMakeLists.txt b/examples/sets-translate/CMakeLists.txt
index e69de29bb..8676994fd 100644
--- a/examples/sets-translate/CMakeLists.txt
+++ b/examples/sets-translate/CMakeLists.txt
@@ -0,0 +1,8 @@
+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin/examples/sets-translate)
+
+add_executable(sets2arrays EXCLUDE_FROM_ALL sets_translate.cpp)
+target_link_libraries(sets2arrays cvc4 cvc4parser)
+
+add_executable(sets2axioms EXCLUDE_FROM_ALL sets_translate.cpp)
+target_compile_definitions(sets2axioms PRIVATE -DENABLE_AXIOMS)
+target_link_libraries(sets2axioms cvc4 cvc4parser)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback