summaryrefslogtreecommitdiff
path: root/examples/nra-translate/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/nra-translate/CMakeLists.txt')
-rw-r--r--examples/nra-translate/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/examples/nra-translate/CMakeLists.txt b/examples/nra-translate/CMakeLists.txt
new file mode 100644
index 000000000..b719ac2a4
--- /dev/null
+++ b/examples/nra-translate/CMakeLists.txt
@@ -0,0 +1,24 @@
+set(EXAMPLES_NRA_TRANSLATE_BIN_DIR ${EXAMPLES_BIN_DIR}/nra-translate)
+
+set(CVC4_EXAMPLES_NRA_TRANSLATE
+ normalize
+ smt2info
+ smt2todreal
+ smt2toisat
+ smt2tomathematica
+ smt2toqepcad
+ smt2toredlog
+)
+
+set(EXAMPLES_NRA_TRANSLATE_LINK_LIBS cvc4 cvc4parser)
+foreach(example ${CVC4_EXAMPLES_NRA_TRANSLATE})
+ cvc4_add_example(${example}
+ "" "${EXAMPLES_NRA_TRANSLATE_LINK_LIBS}" "nra-translate"
+ # arguments to binary (for testing)
+ # input file is required by all tests
+ ${CMAKE_CURRENT_SOURCE_DIR}/nra-translate-example-input.smt2
+ # This is a dummy argument for smt2toredlog (argument is only printed, can
+ # be anything for testing purposes). We pass this to all examples since the
+ # other examples ignore additional arguments.
+ "foo")
+endforeach()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback