summaryrefslogtreecommitdiff
path: root/examples/api/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/api/Makefile.am')
-rw-r--r--examples/api/Makefile.am32
1 files changed, 19 insertions, 13 deletions
diff --git a/examples/api/Makefile.am b/examples/api/Makefile.am
index 3508f9900..a1455d168 100644
--- a/examples/api/Makefile.am
+++ b/examples/api/Makefile.am
@@ -6,18 +6,19 @@ AM_CXXFLAGS = -Wall
AM_CFLAGS = -Wall
noinst_PROGRAMS = \
- linear_arith \
- helloworld \
- combination \
bitvectors \
bitvectors_and_arrays \
- datatypes
+ combination \
+ datatypes \
+ helloworld \
+ linear_arith \
+ sets
noinst_DATA =
-linear_arith_SOURCES = \
- linear_arith.cpp
-linear_arith_LDADD = \
+bitvectors_SOURCES = \
+ bitvectors.cpp
+bitvectors_LDADD = \
@builddir@/../../src/libcvc4.la
bitvectors_and_arrays_SOURCES = \
@@ -30,6 +31,11 @@ combination_SOURCES = \
combination_LDADD = \
@builddir@/../../src/libcvc4.la
+datatypes_SOURCES = \
+ datatypes.cpp
+datatypes_LDADD = \
+ @builddir@/../../src/libcvc4.la
+
helloworld_SOURCES = \
helloworld.cpp
helloworld_CXXFLAGS = \
@@ -37,14 +43,14 @@ helloworld_CXXFLAGS = \
helloworld_LDADD = \
@builddir@/../../src/libcvc4.la
-bitvectors_SOURCES = \
- bitvectors.cpp
-bitvectors_LDADD = \
+linear_arith_SOURCES = \
+ linear_arith.cpp
+linear_arith_LDADD = \
@builddir@/../../src/libcvc4.la
-datatypes_SOURCES = \
- datatypes.cpp
-datatypes_LDADD = \
+sets_SOURCES = \
+ sets.cpp
+sets_LDADD = \
@builddir@/../../src/libcvc4.la
# for installation
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback