summaryrefslogtreecommitdiff
path: root/examples/api/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/api/Makefile.am')
-rw-r--r--examples/api/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/examples/api/Makefile.am b/examples/api/Makefile.am
new file mode 100644
index 000000000..937a76d36
--- /dev/null
+++ b/examples/api/Makefile.am
@@ -0,0 +1,26 @@
+AM_CPPFLAGS = \
+ -I@srcdir@/../../src/include -I@srcdir@/../../src -I@builddir@/../../src $(ANTLR_INCLUDES)
+AM_CXXFLAGS = -Wall
+AM_CFLAGS = -Wall
+
+noinst_PROGRAMS = \
+ linear_arith \
+ helloworld
+
+
+noinst_DATA =
+
+linear_arith_SOURCES = \
+ linear_arith.cpp
+linear_arith_LDADD = \
+ @builddir@/../../src/libcvc4.la
+
+
+helloworld_SOURCES = \
+ helloworld.cpp
+helloworld_LDADD = \
+ @builddir@/../../src/libcvc4.la
+
+# for installation
+examplesdir = $(docdir)/$(subdir)
+examples_DATA = $(DIST_SOURCES) $(EXTRA_DIST)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback