summaryrefslogtreecommitdiff
path: root/examples/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/api/CMakeLists.txt')
-rw-r--r--examples/api/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/examples/api/CMakeLists.txt b/examples/api/CMakeLists.txt
index 7b713e6e7..bff7caa4d 100644
--- a/examples/api/CMakeLists.txt
+++ b/examples/api/CMakeLists.txt
@@ -24,11 +24,18 @@ set(CVC5_EXAMPLES_API
sets
sequences
strings
+)
+
+foreach(example ${CVC5_EXAMPLES_API})
+ cvc5_add_example(${example} "" "api")
+endforeach()
+
+set(SYGUS_EXAMPLES_API
sygus-fun
sygus-grammar
sygus-inv
)
-foreach(example ${CVC5_EXAMPLES_API})
- cvc5_add_example(${example} "" "api")
+foreach(example ${SYGUS_EXAMPLES_API})
+ cvc5_add_example(${example} "${example}.cpp utils.h utils.cpp" "api")
endforeach()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback