summaryrefslogtreecommitdiff
path: root/docs/python/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'docs/python/CMakeLists.txt')
-rw-r--r--docs/python/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/docs/python/CMakeLists.txt b/docs/python/CMakeLists.txt
new file mode 100644
index 000000000..cdac14de0
--- /dev/null
+++ b/docs/python/CMakeLists.txt
@@ -0,0 +1,21 @@
+###############################################################################
+# Top contributors (to current version):
+# Gereon Kremer
+#
+# This file is part of the cvc5 project.
+#
+# Copyright (c) 2009-2021 by the authors listed in the file AUTHORS
+# in the top-level source directory and their institutional affiliations.
+# All rights reserved. See the file COPYING in the top-level source
+# directory for licensing information.
+# #############################################################################
+#
+# Build system configuration for python API documentation.
+##
+
+add_custom_target(docs-python)
+
+if (BUILD_BINDINGS_PYTHON)
+ # Python API docs are generated from built python API
+ add_dependencies(docs-python pycvc5)
+endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback