summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 4 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 9ec9923c0..1480879c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1142,19 +1142,10 @@ AM_CONDITIONAL([HAVE_CXXTESTGEN], [test -n "$CXXTESTGEN"])
AC_ARG_VAR(PERL, [PERL interpreter (used when testing)])
-AC_ARG_VAR(PYTHON, [PYTHON interpreter (used for building legacy Java library interface)])
-
-if test -z "$PYTHON"; then
- AC_CHECK_PROGS(PYTHON, python, python, [])
-else
- AC_CHECK_PROG(PYTHON, "$PYTHON", "$PYTHON", [])
-fi
-
-if test -z "$PYTHON"; then
- AC_MSG_WARN([python not found, cannot build libcvc4compat_java (the legacy Java interface).])
- CXXTESTGEN=
- CXXTEST=
-fi
+# Python is now a required dependency for generating options code
+AM_PATH_PYTHON([2.7],, [
+ AC_MSG_ERROR([Python not found.])
+])
# Checks for libraries.
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback