summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ff150844f..f6f2f5a04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -629,17 +629,24 @@ fi
CXXTESTGEN=
AC_PATH_PROG(CXXTESTGEN, cxxtestgen.pl, [], [$CXXTEST:$PATH])
if test -z "$CXXTESTGEN"; then
- AC_MSG_NOTICE([unit tests disabled, cxxtestgen.pl not found.])
+ AC_PATH_PROG(CXXTESTGEN, cxxtestgen.py, [], [$CXXTEST:$PATH])
+fi
+if test -z "$CXXTESTGEN"; then
+ AC_MSG_NOTICE([unit tests disabled, neither cxxtestgen.pl nor cxxtestgen.py found.])
elif test -z "$CXXTEST"; then
CXXTEST=`dirname "$CXXTESTGEN"`
AC_MSG_CHECKING([for location of CxxTest headers])
if test -e "$CXXTEST/cxxtest/TestRunner.h"; then
AC_MSG_RESULT([$CXXTEST])
else
- AC_MSG_RESULT([not found])
- AC_MSG_WARN([unit tests disabled, CxxTest headers not found.])
- CXXTESTGEN=
- CXXTEST=
+ if test -e "/usr/include/cxxtest/TestRunner.h"; then
+ AC_MSG_RESULT([/usr/include])
+ else
+ AC_MSG_RESULT([not found])
+ AC_MSG_WARN([unit tests disabled, CxxTest headers not found.])
+ CXXTESTGEN=
+ CXXTEST=
+ fi
fi
fi
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback