summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d2c08661b..7da86d8a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,6 +253,27 @@ AC_PROG_INSTALL
CVC4_GCC_VERSION
+if test $cross_compiling = "no"; then
+ AC_MSG_CHECKING([whether C++ exceptions work])
+ AC_LANG_PUSH([C++])
+ AC_RUN_IFELSE(
+ AC_LANG_PROGRAM([#include <exception>], [[
+ int result = 1;
+ try {
+ throw std::exception();
+ } catch (...) {
+ result = 0;
+ }
+ return result;
+ ]]),
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_ERROR([C++ exceptions do not work.])]
+ )
+ AC_LANG_POP([C++])
+else
+ AC_MSG_WARN([Cross compiling, cannot check whether exceptions work])
+fi
+
cvc4_use_gmp=2
cvc4_use_cln=2
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback