summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 68d7bf026..b4471a0fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,7 +272,7 @@ if test $cvc4_use_cln = 1; then
PKG_CHECK_MODULES([CLN], [cln >= 1.2.2],
[cvc4_use_cln=1
AC_LANG_PUSH([C++])
- AC_LINK_IFELSE(AC_LANG_PROGRAM([[#include <cln/cln.h>]], [[cln::cl_F pi = "3.1415926";]]))
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <cln/cln.h>]], [[cln::cl_F pi = "3.1415926";]])])
AC_LANG_POP([C++])
],
[if test $cvc4_use_cln = 0; then
@@ -688,10 +688,10 @@ fi
# See src/util/hash.h.
AC_MSG_CHECKING([whether __gnu_cxx::hash<uint64_t> is already specialized])
AC_LANG_PUSH([C++])
-AC_COMPILE_IFELSE(AC_LANG_SOURCE([
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include <stdint.h>
#include <ext/hash_map>
-namespace __gnu_cxx { template<> struct hash<uint64_t> {}; }]),
+namespace __gnu_cxx { template<> struct hash<uint64_t> {}; }])],
[AC_MSG_RESULT([no]); CVC4CPPFLAGS="${CVC4CPPFLAGS:+$CVC4CPPFLAGS }-DCVC4_NEED_HASH_UINT64_T"],
[AC_MSG_RESULT([yes])])
AC_LANG_POP([C++])
@@ -1084,6 +1084,8 @@ CVC4_CONFIG_FILE_ONLY_IF_CHANGED([doc/libcvc4.3])
CVC4_CONFIG_FILE_ONLY_IF_CHANGED([doc/libcvc4parser.3])
CVC4_CONFIG_FILE_ONLY_IF_CHANGED([doc/libcvc4compat.3])
+# AC_CONFIG_SUBDIRS([src/prop/cryptominisat])
+
AC_OUTPUT
# Final information to the user
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback