summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 13 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index d2b11fe9c..db74bd378 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,11 @@ AUTOMAKE_OPTIONS = foreign
ACLOCAL_AMFLAGS = -I config
SUBDIRS = src test contrib
+DIST_SUBDIRS = $(SUBDIRS) examples
+
+.PHONY: examples
+examples: all
+ (cd examples && $(MAKE) $(AM_MAKEFLAGS))
.PHONY: units systemtests regress regress0 regress1 regress2 regress3
systemtests regress regress0 regress1 regress2 regress3: all
@@ -32,8 +37,8 @@ if COVERAGE_ENABLED
# work...)
lcov: all
$(LCOV) -z -d .
- $(MAKE) check -C src
- +$(MAKE) check -C test/unit
+ (cd src && $(MAKE) $(AM_MAKEFLAGS) check)
+ +(cd test/unit && $(MAKE) $(AM_MAKEFLAGS) check)
$(LCOV) -c -d . -t cvc4_units -o cvc4-coverage-full.info
$(LCOV) -o cvc4-coverage.info -r cvc4-coverage-full.info $(LCOV_EXCLUDES)
mkdir -p "@top_srcdir@/html"
@@ -44,8 +49,8 @@ lcov: all
lcov-all: all
$(LCOV) -z -d .
- $(MAKE) check -C src
- +$(MAKE) check -C test
+ (cd src && $(MAKE) $(AM_MAKEFLAGS) check)
+ +(cd test && $(MAKE) $(AM_MAKEFLAGS) check)
$(LCOV) -c -d . -t cvc4_units -o cvc4-coverage-full.info
$(LCOV) -o cvc4-coverage.info -r cvc4-coverage-full.info $(LCOV_EXCLUDES)
mkdir -p "@top_srcdir@/html"
@@ -62,10 +67,10 @@ lcov18: all
echo; echo "=== Collecting coverage data from $$testtype unit tests ==="; \
echo $(LCOV) -z -d .; \
$(LCOV) -z -d . || exit 1; \
- echo $(MAKE) check -C src || exit 1; \
- $(MAKE) check -C src || exit 1; \
- echo $(MAKE) check -C test/unit TEST_SUFFIX=_$$testtype || exit 1; \
- $(MAKE) check -C test/unit TEST_SUFFIX=_$$testtype || exit 1; \
+ echo "(cd src && $(MAKE) $(AM_MAKEFLAGS) check) || exit 1"; \
+ (cd src && $(MAKE) $(AM_MAKEFLAGS) check) || exit 1; \
+ echo "(cd test/unit && $(MAKE) $(AM_MAKEFLAGS) check TEST_SUFFIX=_$$testtype) || exit 1"; \
+ (cd test/unit && $(MAKE) $(AM_MAKEFLAGS) check TEST_SUFFIX=_$$testtype) || exit 1; \
echo $(LCOV) -c -d . -t $$testtype -o cvc4-coverage-$$testtype-full.info || exit 1; \
$(LCOV) -c -d . -t $$testtype -o cvc4-coverage-$$testtype-full.info || exit 1; \
echo $(LCOV) -o cvc4-coverage-$$testtype.info -r cvc4-coverage-$$testtype-full.info $(LCOV_EXCLUDES); \
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback