summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 76130be45..07a91f21a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,8 +5,15 @@ ACLOCAL_AMFLAGS = -I config
SUBDIRS = src test doc contrib
+@mk_include@ @top_srcdir@/Makefile.reconf_args
+
.PHONY: production debug default competition
-production: ; (cd @top_srcdir@ && ./configure --with-build=production && $(MAKE))
-debug: ; (cd @top_srcdir@ && ./configure --with-build=debug && $(MAKE))
-default: ; (cd @top_srcdir@ && ./configure --with-build=default && $(MAKE))
-competition:; (cd @top_srcdir@ && ./configure --with-build=competition && $(MAKE))
+production debug default competition:
+ cd @top_srcdir@; \
+ dir="builds/`config/config.guess`/`config/build-type $@ $(BTARGS)`"; \
+ if test -e "$$dir"; then \
+ cd "$$dir" && $(MAKE); \
+ else \
+ ./configure --with-build=$@ $(CONFARGS) && $(MAKE); \
+ fi
+
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback