summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e850f9928..435407fea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -196,6 +196,9 @@ endif()
# Never build unit tests as static binaries, otherwise we'll end up with
# ~300MB per unit test.
if(ENABLE_UNIT_TESTING)
+ if(NOT ENABLE_SHARED)
+ message(WARNING "Disabling static build since unit testing is enabled.")
+ endif()
set(ENABLE_SHARED ON)
endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback