summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 885577260..945f71d36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,6 +243,10 @@ add_check_c_cxx_flag("-Wshadow")
# cdlist.h warnings. Remove when fixed.
add_check_cxx_flag("-Wno-class-memaccess")
+if (WIN32)
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--stack,100000000")
+endif ()
+
#-----------------------------------------------------------------------------#
# Use ld.gold if available
@@ -670,6 +674,7 @@ message("")
message("CPPLAGS (-D...) : ${CVC4_DEFINITIONS}")
message("CXXFLAGS : ${CMAKE_CXX_FLAGS}")
message("CFLAGS : ${CMAKE_C_FLAGS}")
+message("Linker flags : ${CMAKE_EXE_LINKER_FLAGS}")
message("")
message("Install prefix : ${CMAKE_INSTALL_PREFIX}")
message("")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback