summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 23a52db59..69f990903 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -228,6 +228,9 @@ if(ENABLE_ASSERTIONS)
add_definitions(-DCVC4_ASSERTIONS)
else()
add_definitions(-DNDEBUG)
+ # Only enable unit testing if assertions are enabled. Otherwise, unit tests
+ # that expect AssertionException to be thrown will fail.
+ set(ENABLE_UNIT_TESTING OFF)
endif()
if(ENABLE_COVERAGE)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback