summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 617ca2780..bbdc863bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -245,10 +245,6 @@ if(ENABLE_DEBUG_CONTEXT_MM)
add_definitions(-DCVC4_DEBUG_CONTEXT_MEMORY_MANAGER)
endif()
-if(ENABLE_DUMPING)
- add_definitions(-DCVC4_DUMPING)
-endif()
-
if(ENABLE_DEBUG_SYMBOLS)
add_check_c_cxx_flag("-ggdb3")
endif()
@@ -260,6 +256,9 @@ endif()
# This check needs to come before the USE_CLN check.
if(ENABLE_PORTFOLIO)
find_package(Boost 1.50.0 REQUIRED COMPONENTS thread)
+ if (ENABLE_DUMPING)
+ message(FATAL_ERROR "Dumping not supported with a portfolio build.")
+ endif()
# Disable CLN for portfolio builds since it is not thread safe (uses an
# unlocked hash table internally).
if(USE_CLN)
@@ -275,6 +274,11 @@ if(ENABLE_PORTFOLIO)
set(BOOST_HAS_THREAD_ATTR 1)
endif()
+# This has to be processed after ENABLE_PORTFOLIO (disables dumping support).
+if(ENABLE_DUMPING)
+ add_definitions(-DCVC4_DUMPING)
+endif()
+
if(ENABLE_PROFILING)
add_definitions(-DCVC4_PROFILING)
add_check_c_cxx_flag("-pg")
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback