summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000..9e3580fbb
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,23 @@
+cmake_minimum_required (VERSION 2.8.9)
+
+macro(add_cxx_flag flag)
+ message(STATUS "Configure with flag '${flag}'")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${flag}")
+endmacro()
+
+project (cvc4)
+
+set (CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)
+
+# TODO: cln
+find_package(GMP REQUIRED)
+set(LIBRARIES ${LIBRARIES} ${GMP_LIBRARIES})
+include_directories(${GMP_INCLUDE_DIR})
+
+add_subdirectory(src)
+add_subdirectory(test)
+#TODO only if with-lfsc
+#add_subdirectory(proofs/signatures)
+
+#TODO make dist (subdir: examples)
+
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback