summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02cf58ed1..34281a5f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -226,10 +226,17 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR})
set(CVC4_NEED_INT64_T_OVERLOADS 0)
set(CVC4_USE_CLN_IMP 0)
set(CVC4_USE_GMP_IMP 1)
+
set(CVC4_USE_SYMFPU 0)
+set(CVC4_PROOF 0)
+
#-----------------------------------------------------------------------------#
add_subdirectory(doc)
-add_subdirectory(proofs/signatures)
add_subdirectory(src)
+
+if(CVC4_PROOF)
+ add_subdirectory(proofs/signatures)
+ set(LIBRARIES ${LIBRARIES} signatures)
+endif()
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback