summaryrefslogtreecommitdiff
path: root/test/unit/parser/CMakeLists.txt
diff options
context:
space:
mode:
authorAina Niemetz <aina.niemetz@gmail.com>2018-09-19 09:21:31 -0700
committerMathias Preiner <mathias.preiner@gmail.com>2018-09-22 16:30:59 -0700
commit65a713e53cefa95fcff1b2db30046edf943b3390 (patch)
treef2a00a78087c604c48f3bb40a2cbe72f3458e5cf /test/unit/parser/CMakeLists.txt
parentbd5067d49cc113750887b62f865df8048c648cce (diff)
cmake: Refactor cvc4_add_unit_test macro to support test names with '/'.
Required for consistent naming of tests, unit test names now also use the test naming scheme <category>/<subdir>/<test name>, e.g., unit/theory/theory_bv_white.
Diffstat (limited to 'test/unit/parser/CMakeLists.txt')
-rw-r--r--test/unit/parser/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/unit/parser/CMakeLists.txt b/test/unit/parser/CMakeLists.txt
index debe8a4ce..37204f0c3 100644
--- a/test/unit/parser/CMakeLists.txt
+++ b/test/unit/parser/CMakeLists.txt
@@ -1,5 +1,5 @@
#-----------------------------------------------------------------------------#
# Add unit tests
-cvc4_add_unit_test_black(parser_black)
-cvc4_add_unit_test_black(parser_builder_black)
+cvc4_add_unit_test_black(parser_black parser)
+cvc4_add_unit_test_black(parser_builder_black parser)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback