summaryrefslogtreecommitdiff
path: root/test/unit/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2009-12-16 04:25:45 +0000
committerMorgan Deters <mdeters@gmail.com>2009-12-16 04:25:45 +0000
commit79df573326e6911d3a97fcc2528105acd1c2c525 (patch)
tree70930bcdb620cdf8ff9e3e9c495f67ed8317aa2e /test/unit/Makefile.am
parent8cb3a7b556e8b4b85745bffbd1f0246e6af29588 (diff)
Fixes to the build system:
Makefile.am files - remove obsolete INCLUDES, incorporate into AM_CPPFLAGS Makefile files in src/ - support "make" under src/ (current build profile) configure.ac - updates to fix warnings config/antlr.m4 - updates to fix warnings autogen.sh - updates to generate warnings from autotools; also support Macs src/include/cvc4_config.h - guard with #ifdef total reimplementation of NodeBuilder ExprValue => NodeValue context_mm.{h,cpp} - fixed numerous compile errors
Diffstat (limited to 'test/unit/Makefile.am')
-rw-r--r--test/unit/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/test/unit/Makefile.am b/test/unit/Makefile.am
index d6908cef9..e10856bba 100644
--- a/test/unit/Makefile.am
+++ b/test/unit/Makefile.am
@@ -1,19 +1,27 @@
if HAVE_CXXTESTGEN
-AM_CPPFLAGS = -I. "-I$(CXXTEST)" "-I@top_srcdir@/src/include" "-I@top_srcdir@/src"
+AM_CPPFLAGS = \
+ -I. "-I@CXXTEST@" "-I@top_srcdir@/src/include" "-I@top_srcdir@/src"
AM_CXXFLAGS = -fno-access-control
#AM_LDFLAGS = -L@top_builddir@/src/libcvc4.la
+
+TESTS_WHITE = \
+ expr/node_white
+
+TESTS_BLACK = \
+ expr/node_black
+
TESTS = \
- expr/expr_black \
- expr/expr_white
+ $(TESTS_WHITE) \
+ $(TESTS_BLACK)
lib_LTLIBRARIES = libdummy.la
-libdummy_la_SOURCES = expr/expr_black.cpp
+libdummy_la_SOURCES = expr/node_black.cpp
libdummy_la_LIBADD = @abs_top_builddir@/src/libcvc4.la
$(TESTS:%=%.cpp): %.cpp: %.h
mkdir -p `dirname "$@"`
- $(CXXTESTGEN) --have-eh --have-std --error-printer -o "$@" "$<"
+ @CXXTESTGEN@ --have-eh --have-std --error-printer -o "$@" "$<"
$(TESTS): %: %.cpp
# get these in here somehow
# $(TEST_CPPFLAGS) $(TEST_CXXFLAGS) $(TEST_LDFLAGS)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback