summaryrefslogtreecommitdiff
path: root/test/unit/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2010-02-22 20:33:00 +0000
committerMorgan Deters <mdeters@gmail.com>2010-02-22 20:33:00 +0000
commit7c143dc5d5a52664a3cecca5226df57269063162 (patch)
tree4ac4c1af00a8d1c278ed5d59c8e16f3c7b4df5c3 /test/unit/Makefile.am
parent09279d722aa6e62e86eb4b34583397db1093051e (diff)
* configure.ac: Remove doc/ from search path for Makefile.ams
* configure.ac, test/unit/Makefile.am: Resolved an issue where even when not testing, one unit test was built. * Re-ran contrib/update-copyright.pl on all source files to ensure consistent and correct header comments. * contrib/get-authors: Change definition of "minor contributor" to >= 10% of lines (rather than strictly greater than 10% of lines)
Diffstat (limited to 'test/unit/Makefile.am')
-rw-r--r--test/unit/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/test/unit/Makefile.am b/test/unit/Makefile.am
index c145cf752..591a85202 100644
--- a/test/unit/Makefile.am
+++ b/test/unit/Makefile.am
@@ -51,11 +51,6 @@ EXTRA_DIST = \
no_cxxtest \
$(TEST_DEPS_DIST)
-# without these here, LTCXXCOMPILE, CXXLINK, etc., aren't set :-(
-noinst_LTLIBRARIES = libdummy.la
-libdummy_la_SOURCES = expr/node_black.cpp
-libdummy_la_LIBADD = @abs_top_builddir@/src/libcvc4.la
-
MOSTLYCLEANFILES = $(UNIT_TESTS) $(UNIT_TESTS:%=%.cpp)
@mk_include@ @srcdir@/Makefile.tests
@@ -88,6 +83,13 @@ EXTRA_DIST = \
endif
+# trick automake into setting LTCXXCOMPILE, CXXLINK, etc.
+if CVC4_FALSE
+noinst_LTLIBRARIES = libdummy.la
+libdummy_la_SOURCES = expr/node_black.cpp
+libdummy_la_LIBADD = @abs_top_builddir@/src/libcvc4.la
+endif
+
# synonyms for "check"
.PHONY: regress test
regress test: check
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback