summaryrefslogtreecommitdiff
path: root/test/unit/Makefile.am
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-03-08 16:03:01 -0800
committerGitHub <noreply@github.com>2018-03-08 16:03:01 -0800
commit5d19d98e0720ccaf993c45e2997297751a6fc1ba (patch)
tree4bd77cf568cf22e7c79e4d7bafb2486e28108d2b /test/unit/Makefile.am
parentc6b2e085d4eb2c232a528a96e13fc7b65fd98fea (diff)
Fix Travis for unit test compilation errors. (#1651)
make units does not fail if we have compile error for a unit test, however, make check does. -Wsuggest-override is now explicitly disabled for unit tests since CxxTest does not add override keywords to the generated source code and thus get a lot of compiler warnings. Further, this fixes some issues introduced with #1647 due to make units not failing on Travis and fixes the nightly builds.
Diffstat (limited to 'test/unit/Makefile.am')
-rw-r--r--test/unit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/unit/Makefile.am b/test/unit/Makefile.am
index 167100ff0..3d5f2702d 100644
--- a/test/unit/Makefile.am
+++ b/test/unit/Makefile.am
@@ -81,6 +81,7 @@ AM_CPPFLAGS = \
$(TEST_CPPFLAGS)
AM_CXXFLAGS = -Wall -Wno-unknown-pragmas -Wno-parentheses $(TEST_CXXFLAGS)
AM_LDFLAGS = $(TEST_LDFLAGS) $(READLINE_LIBS) $(LIBS)
+CXXFLAGS=-Wno-suggest-override
AM_CXXFLAGS_WHITE = -fno-access-control -D__BUILDING_CVC4LIB_UNIT_TEST -D__BUILDING_CVC4PARSERLIB_UNIT_TEST
AM_CXXFLAGS_BLACK = -D__BUILDING_CVC4LIB_UNIT_TEST -D__BUILDING_CVC4PARSERLIB_UNIT_TEST
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback