summaryrefslogtreecommitdiff
path: root/test/unit/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2012-07-16 19:00:31 +0000
committerMorgan Deters <mdeters@gmail.com>2012-07-16 19:00:31 +0000
commit1f8da4ffd0887a095994392087d76f376ac006d2 (patch)
treee1c94f40b721bf386eaa791de5cd9a13b0b2966a /test/unit/Makefile.am
parent5ad6726028477de6059a0af83b8870d9d524a7ac (diff)
now passes "make distcheck", which does important checks for the release (e.g., "make dist" produces a distribution that passes "make dist" and "make check", "make uninstall" actually uninstalls, "make distclean" actually cleans, ...)
Diffstat (limited to 'test/unit/Makefile.am')
-rw-r--r--test/unit/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/test/unit/Makefile.am b/test/unit/Makefile.am
index dc53bff61..d5b6ce5bf 100644
--- a/test/unit/Makefile.am
+++ b/test/unit/Makefile.am
@@ -105,7 +105,25 @@ EXTRA_DIST = \
$(UNIT_TESTS:%=%.h) \
$(TEST_DEPS_DIST)
-MOSTLYCLEANFILES = $(UNIT_TESTS) $(UNIT_TESTS:%=%.cpp)
+MOSTLYCLEANFILES = $(UNIT_TESTS) $(UNIT_TESTS:%=%.cpp) $(UNIT_TESTS:%=%.lo)
+
+# the tests automake infrastructure doesn't clean up .o files :-(
+# handle both .libs and _libs variants
+mostlyclean-local:
+ @for f in $(UNIT_TESTS); do \
+ dir="$$(dirname "$$f")"; fil="$$(basename "$$f")"; \
+ for junk in "$$dir/.libs/$$fil.o" \
+ "$$dir/_libs/$$fil.o" \
+ "$$dir/.libs/lt-$$fil" \
+ "$$dir/_libs/lt-$$fil" \
+ "$$dir/.libs/$$fil" \
+ "$$dir/_libs/$$fil"; do \
+ if test -e "$$junk"; then \
+ echo "rm -f \"$$junk\""; \
+ rm -f "$$junk"; \
+ fi; \
+ done; \
+ done
@mk_include@ @srcdir@/Makefile.tests
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback