summaryrefslogtreecommitdiff
path: root/test/unit/Makefile.am
diff options
context:
space:
mode:
authorMorgan Deters <mdeters@gmail.com>2009-12-17 21:05:15 +0000
committerMorgan Deters <mdeters@gmail.com>2009-12-17 21:05:15 +0000
commitdfcf7dba0b2d8ad6eb9d8540e92804e70205b8fb (patch)
tree6cc700c94a4a72e5f4b758803b079dfed059e054 /test/unit/Makefile.am
parentfdc93191d331c6bd4a2934eb5cbeb18d78cb078d (diff)
update-copyright.pl now retrieves and incorporates author information from repository history; re-ran update-copyright.pl; cleaned up some things with make
Diffstat (limited to 'test/unit/Makefile.am')
-rw-r--r--test/unit/Makefile.am46
1 files changed, 30 insertions, 16 deletions
diff --git a/test/unit/Makefile.am b/test/unit/Makefile.am
index d8f321f10..61eef32d5 100644
--- a/test/unit/Makefile.am
+++ b/test/unit/Makefile.am
@@ -1,23 +1,39 @@
+# all unit tests
+UNIT_TESTS = \
+ expr/node_white \
+ expr/node_black \
+ parser/cvc/cvc_parser_black \
+ parser/smt/smt_parser_black
+
+# things that aren't tests but that tests rely on and need to
+# go into the distribution
+TEST_DEPENDENCIES =
+
if HAVE_CXXTESTGEN
AM_CPPFLAGS = \
- -I. "-I@CXXTEST@" "-I@top_srcdir@/src/include" "-I@top_srcdir@/src"
+ -I. "-I@CXXTEST@" "-I@top_srcdir@/src/include" "-I@top_srcdir@/src" \
+ $(TEST_CPPFLAGS)
+AM_CXXFLAGS = $(TEST_CXXFLAGS)
+AM_LDFLAGS = $(TEST_LDFLAGS)
+
AM_CXXFLAGS_WHITE = -fno-access-control
AM_CXXFLAGS_BLACK =
AM_CXXFLAGS_PUBLIC =
AM_LDFLAGS_WHITE = \
- @abs_top_builddir@/src/parser/libcvc4parser_noinst.la \
- @abs_top_builddir@/src/libcvc4_noinst.la
+ @abs_top_builddir@/src/parser/libcvc4parser_noinst.la \
+ @abs_top_builddir@/src/libcvc4_noinst.la
AM_LDFLAGS_BLACK = \
- $(AM_LDFLAGS_WHITE)
+ @abs_top_builddir@/src/parser/libcvc4parser_noinst.la \
+ @abs_top_builddir@/src/libcvc4_noinst.la
AM_LDFLAGS_PUBLIC = \
- @abs_top_builddir@/src/libcvc4.la
+ @abs_top_builddir@/src/libcvc4.la
-TESTS = \
- expr/node_white \
- expr/node_black \
- parser/cvc/cvc_parser_black \
- parser/smt/smt_parser_black
+TESTS = $(UNIT_TESTS)
+
+EXTRA_DIST = \
+ no_cxxtest \
+ $(TEST_DEPENDENCIES)
# without these here, LTCXXCOMPILE, CXXLINK, etc., aren't set :-(
noinst_LTLIBRARIES = libdummy.la
@@ -28,18 +44,12 @@ $(TESTS:%=%.cpp): %.cpp: %.h
mkdir -p `dirname "$@"`
@CXXTESTGEN@ --have-eh --have-std --error-printer -o "$@" "$<"
$(filter %_white,$(TESTS)): %_white: %_white.cpp
-# get these in here somehow
-# $(TEST_CPPFLAGS) $(TEST_CXXFLAGS) $(TEST_LDFLAGS)
$(LTCXXCOMPILE) $(AM_CXXFLAGS_WHITE) -c -o $@.lo $<
$(CXXLINK) $(AM_LDFLAGS_WHITE) $@.lo
$(filter %_black,$(TESTS)): %_black: %_black.cpp
-# get these in here somehow
-# $(TEST_CPPFLAGS) $(TEST_CXXFLAGS) $(TEST_LDFLAGS)
$(LTCXXCOMPILE) $(AM_CXXFLAGS_BLACK) -c -o $@.lo $<
$(CXXLINK) $(AM_LDFLAGS_BLACK) $@.lo
$(filter %_public,$(TESTS)): %_public: %_public.cpp
-# get these in here somehow
-# $(TEST_CPPFLAGS) $(TEST_CXXFLAGS) $(TEST_LDFLAGS)
$(LTCXXCOMPILE) $(AM_CXXFLAGS_PUBLIC) -c -o $@.lo $<
$(CXXLINK) $(AM_LDFLAGS_PUBLIC) $@.lo
@@ -50,4 +60,8 @@ else
# force a user-visible failure for "make check"
TESTS = no_cxxtest
+EXTRA_DIST = \
+ $(UNIT_TESTS) \
+ $(TEST_DEPENDENCIES)
+
endif
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback