summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorMathias Preiner <mathias.preiner@gmail.com>2018-10-01 15:53:30 -0700
committerGitHub <noreply@github.com>2018-10-01 15:53:30 -0700
commit968d12fb8dc668dde59b02923a6b9ec20ecbeb3f (patch)
tree41bd185dfea8fbf29bb5b083d38e49b3a40c3d9c /test/unit/CMakeLists.txt
parent6b718154dfbf5e9f8506d6911201bb7398ba8b48 (diff)
cmake: Add build target build-tests to build all test dependencies. (#2558)
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index d362870c1..aa9248e6c 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -14,10 +14,7 @@ include_directories(${CMAKE_BINARY_DIR}/src)
# > unit tests
add_custom_target(build-units)
-add_dependencies(check build-units)
-if(ENABLE_COVERAGE)
- add_dependencies(coverage build-units)
-endif()
+add_dependencies(build-tests build-units)
add_custom_target(units
COMMAND ctest --output-on-failure -L "unit" -j${CTEST_NTHREADS} $(ARGS)
generated by cgit on debian on lair
contact matthew@masot.net with questions or feedback